Some quotes aren't populating correctly from portal applications

Incident Report for AI Insurance

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 17:09 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 31, 2025 - 18:03 UTC
This incident affected: Application.